Page 1 of 1

Probleme mit Elementenregel

PostPosted: 2011-03-28 16:39
by markus-fe
Systeminformationen: [ Citavi Version 3.0.12, Windows 7, Deutsch, Firefox 3.x, MS Office 2007, Acrobat 9 ]

Liebes Support-Team,

momentan arbeite ich an einem Zitationsstil und bin begeistert, wie intuitiv das alles funktioniert. Probleme bereitet mir nur eine Sache: Bei Zeitschriftenaufsätzen möchte ich hinter der Jahrgangszahl die Beschriftung ".Jg." hinzufügen, so dass die Anzeige nachher so aussieht: 13.Jg. (allerdings nur wenn auch ein Jahrgang angegeben ist).

Dazu habe ich die Jahrgangskomponente ausgewählt und als ".Jg."-Beschriftung ein neues Textelement erstellt (s. Screenshot). Das funktioniert auch wunderbar, das ".Jg." verschwindet allerdings, wenn ich die Regel anwende, dass die ".Jg."-Beschriftung nur dann angezeigt werden soll, wenn das vorhergehende Element Daten enthält - auch wenn sich definitiv Daten darin befinden.

Ich habe zwei Screenshots und auch die CCS-Datei angehängt.

Ich bedanke mich im Voraus herzlich für Ihre Hilfe!

Beste Grüße
Markus

Re: Probleme mit Elementenregel  Topic is solved

PostPosted: 2011-03-28 16:54
by thomas.riehm
Ich würde statt des selbständigen Textelements "Jg" eher ein neues Element "Jahrgang Jg" anlegen (durch Duplizieren der Komponente "Jahrgang"), das aus dem Basiselement "Jahrgang" und einem Textelement "Jg" besteht. Das verbindet dann beide Teile und erscheint insgesamt entweder ganz oder gar nicht, je nachdem, ob das Element "Jahrgang" Daten enthält oder nicht.

Wollen Sie das mal probieren?

Beste Grüße
Thomas Riehm

Re: Probleme mit Elementenregel

PostPosted: 2011-03-28 17:15
by markus-fe
Funktioniert einwandfrei, danke!

Beste Grüße
Markus