Picker for Firefox

Got questions about Citavi 4? The Citavi team and other users are happy to help.

Picker for Firefox

Postby alainsr » 2017-11-13 14:57

System information: [ Citavi Version 4.5, Windows 8.x, Other language, Firefox 43 or newer, -, - ]

Latest Citavi Picker addon for Firefox (version 2017.11.7.21) doesn't recognize that Citavi is open and doesn't send anything to Citavi. I am using latest stable Firefox version (56.0.2, 64-bit) and latest Citavi 4 (4.6.0.0). When I right click the Citavi Picker main icon it gives the option to start Citavi, as if it wasn't open already, and clicking its icon after a DOI address for instance makes nothing.

One needs to use latest Firefox version, not outdated ones, mainly for security purposes, and therefore Citavi Picker also needs to be up to date. And I have a valid license for Citavi 4, which includes its Picker for Firefox, so why am I not being able to use it? I have uninstalling and reinstalling each and every part involved (Citavi, Citavi Picker, Firefox) and it still doesn't work...
alainsr
 

Re: Picker for Firefox

Postby Damien Reddy » 2017-11-13 18:16

Hello,

Thank you for your inquiry.

The new version of Firefox released on December 15, 2015 automatically disables unverified add-ons. The update to Citavi 5.2 (release date: October 27, 2015) includes a verified version of the Picker for Firefox.

To continue using the Picker for Firefox, either install the update from Citavi 5.0 or 5.1 or upgrade from Citavi 3 or Citavi 4. For additional information see http://service.citavi.com/news/197/fire ... sions.aspx

If you are working with Citavi 4 and cannot install the upgrade for some reason, please use the following workaround:

Uninstall the Picker by switching to the Control Panel.

Click Programs and Features > Citavi 4 > Change.

Next to Picker for Firefox select This feature will not be available and continue through the Setup.

In Firefox add the Picker from the following webpage: https://addons.mozilla.org/de/firefox/a ... avi-picker.

Please note that we cannot offer any support for this workaround if the Picker does not behave as expected.

Kind regards,
Damien

Did we answer your question to your satisfaction? If so, please click the green check mark in the upper-right corner of this post. This helps other users find solutions to their questions.
Damien Reddy
Citavi Customer Service
 

Re: Picker for Firefox

Postby alainsr » 2017-11-14 15:09

Thank you for the information. But Citavi 4's license includes Citavi Picker, doesn't it? So neither forcing users to keep Firefox outdated (i.e., insecure) nor forcing a (paid) upgrade are legally valid solutions, are they?
alainsr
 

Re: Picker for Firefox

Postby Damien Reddy » 2017-11-20 15:10

Hello,

Unfortunately, as third party programs progress, old software is often no longer compatible, and requires an upgrade. While it is correct that the license includes the Citavi Picker, we retain the right to release updates and bug fixes at our sole discretion and in accordance with the resources available to us. It is not possible for us to keep track with all current browser development for all old versions of Citavi.

Citavi 4 users are of course not forced to use outdated versions of Firefox. Instead, please switch to Google Chrome or Microsoft Internet Explorer. Alternatively, you may also copy a website’s URL into the corresponding fields in Citavi.

Please note that if you previously purchased a Citavi 4 license, you are eligible for an upgrade discount of 50% when purchasing Citavi 5. Purchasing Citavi 5 now falls in the grace period, which allows for a free upgrade to Citavi 6, due for release by the end of the year.

Kind regards,
Damien
Damien Reddy
Citavi Customer Service
 


Return to Citavi 4 Support (English)